Project

General

Profile

Support #362

weights for longitudinal analysis

Added by Anonymous over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Weights
Target version:
Start date:
04/27/2015
Due date:
% Done:

100%

Estimated time:

Description

Dear Alita Nandi,

I am postgraduate student aat the University of Lund. I am working on my final dissertation and I am using the UKHLS survey. I want to study the so-called Healthy Immigrant Effect which says that immigrants tend to be healthier than native-born when they arrive to the country, but they converge to the health of natives as time passes.

It is the first time that I use the UKHLS survey and I have used the material of the online course, in particular the weighting section. I must admit that everything is really well explained and do files are specially helpful. However, I still have a doubt about which weight to pick for my analysis and I was wondering if you could help me on that.

To first study the inequalitites in health status between immigrants and natives I will use the wave 1. Therefore I think tthat I have to use the weight a_indpxus_xw since I am using adult main and proxy interview data.

To study the "health assymilation effect", i.e: wether immigrants´ health converge to native levels, I plan to run a regression where the dependent variable is the difference in health between wave 4 and wave 1. I will include as explanatory variables country of origin and other control variables for wave 1. Since in this model I will also use data from wave 4 (health status in wave 4) I am guessing that if I use the cross-section weight for wave 1, I won´t be controlling for attrition. Therefore, I am really confused about what weight I should use. I would really appreciate if you could give me any advice about it.

Thanks in advance

History

#1 Updated by Alita Nandi over 5 years ago

ANS to Q1 ("To first study the inequalities...."): Yes, if you are using information that are available for full and proxy respondents in wave 1 then use a_indpxus_xw but if you include even one variable that is not available for proxy respondents, then your final analysis sample will include only full respondents. In that case use a_indinus_xw.

ANS to Q2 ("To study the "health..."): You will have to use d_indinus_lw. Note that these weights will be zero for anyone who has missed at least one interview between waves 2-4. So, in effect your analysis sample will consist of those who responded continuously at waves 1 to 4.

#2 Updated by Redmine Admin over 5 years ago

  • Status changed from New to In Progress
  • Target version set to X M
  • % Done changed from 0 to 50

#3 Updated by Redmine Admin over 5 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF