Project

General

Profile

Support #492

Identifying HRP in UndSoc - comparable with BHPS HRP

Added by Gabriella Melis over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/26/2016
Due date:
% Done:

100%

Estimated time:

Description

Hi,

please, I have already seen that this same query was dealt with around a year ago here: https://www.understandingsociety.ac.uk/support/issues/290#note-4; however, the suggested link with the tips to compute an indicator variable for the HRP in UndSoc is not working.

Could you please reactivate that link?

Many thanks.

Gabriella

History

#1 Updated by Victoria Nolan over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Gabriella Melis
  • % Done changed from 0 to 70

Dear Gabriella,

Many thanks for your enquiry, and apologies for any confusion. I think in that earlier issue, the link simply takes you back to an earlier point in the post, where the following advice was given:

In the BHPS as all relationships within the household were identified with respect to the household reference person (HRP), the HRP indicator variable was computed. In Understanding Society (UKHLS) everyone's relationship is asked with respect to everyone else, so HRP is not needed and hence not computed. If you need that variable you will have to compute it yourself. The definition of HRP is the person who owns or rents the accommodation and if more than one, the eldest.

Both in the BHPS and Understanding Society, the household questionnaire is completed by someone who knows most about household payments like bills, rent etc. In most cases this is the HRP but not always. If you want to know the person who answers the household questionnaire then that information is available in the variables, w_ivh* (in UKHLS) and wivh* (in BHPS).

I hope this (plus the responses to the earlier issue #290) helps? Please don't hesitate to ask if you would like some additional help.

Best wishes, Victoria.

On behalf of the Understanding Society User Support Team.

#2 Updated by Gabriella Melis over 4 years ago

Hi,

Thank you for your answer below.

Hence, for UndSoc we must assume that the person who answered the HH questionnaire is the HRP, whilst in BHPS this was completely clear, right? Or is there a more precise solution, please?

Considering this issue, may you please suggest the best way (and the variable names) to compute for UndSoc a variable that reproduces the same information available in the BHPS EGOALT file for the wrel variable:
-HRP
-their live-in partners
-their offspring (18+ yo)

Thank you very much.

Best wishes,

Gabriella

#3 Updated by Gabriella Melis over 4 years ago

Gabriella Melis wrote:

Hi,

Thank you for your answer below.

Hence, for UndSoc we must assume that the person who answered the HH questionnaire is the HRP, whilst in BHPS this was completely clear, right? Or is there a more precise solution, please?

Considering this issue, may you please suggest the best way (and the variable names) to compute for UndSoc a variable that reproduces the same information available in the BHPS EGOALT file for the wrel variable:
-HRP
-their live-in partners
-their offspring (18+ yo)

Thank you very much.

Best wishes,

Gabriella

#4 Updated by Alita Nandi over 4 years ago

  • % Done changed from 70 to 90

Hello Gabriella,

You can construct the hrp variable for Understanding Society using the variables:
w_hidp, w_pno, w_hsownd, w_hsowr1*, w_rentp*, w_dvage

But there will be few households for whom you will not be able to construct the variable due to:
(1) house is netiher owned nor rented (w_hsownd = 97)
(2) house owner or renter is someone outside the household (w_hsowr10 =1 or w_rentp0=1)
(3) house owner or renter information is missing (-9)

Once you have identified the HRP, then you can merge that dataset with the w_egoalt file to identify the live in partner of the HRP and their children. To learn more about how to use the w_egoalt files to construct such relationship variables see Example 8 (Using egoalt files) in the online Stata and SPSS courses:
https://www.understandingsociety.ac.uk/documentation/training/online/
If you use SAS then see the "Using Egoalt Files" example in https://www.understandingsociety.ac.uk/documentation/training/online/sas

I am not sure, but it seems you are saying that the wrel variable in wegoalt files in BHPS shows the relationship between the HRP and others in the household. That is not the case. The wrel variable in the BHPS wegoalt file shows the relationship between every pair of household members.

Hope this helps.

#5 Updated by Victoria Nolan over 4 years ago

  • Assignee changed from Gabriella Melis to Alita Nandi

Gabriella Melis wrote:

Hi,

Thank you for your answer below.

Hence, for UndSoc we must assume that the person who answered the HH questionnaire is the HRP, whilst in BHPS this was completely clear, right? Or is there a more precise solution, please?

Considering this issue, may you please suggest the best way (and the variable names) to compute for UndSoc a variable that reproduces the same information available in the BHPS EGOALT file for the wrel variable:
-HRP
-their live-in partners
-their offspring (18+ yo)

Thank you very much.

Best wishes,

Gabriella

#6 Updated by Alita Nandi over 4 years ago

As explained in Issue# 290

"Both in the BHPS and Understanding Society, the household questionnaire is completed by someone who knows most about household payments like bills, rent etc. In most cases this is the HRP but not always. If you want to know the person who answers the household questionnaire then that information is available in the variables, w_ivh* (in UKHLS) and wivh* (in BHPS)."

If you want to identify family members of the person who answered the household questionnaire, then first identify that person using the variables, w_ivh* (in UKHLS) and wivh* (in BHPS). Then using the egoalt files identify the family mambers of this person.

Hope this helps,
Alita

#7 Updated by Alita Nandi over 4 years ago

  • Assignee changed from Alita Nandi to Gabriella Melis

#8 Updated by Victoria Nolan over 4 years ago

  • Assignee changed from Gabriella Melis to Alita Nandi

Garbiella Melis wrote:

thank you very much for your suggestion, although instead of the w_hsownd I have used the derived tenure variable, and I have not used age as it appeared redundant.

The straighforward and extremely helpful BHPS variable on relationships bewtween the HH members and the HRP I was talking about is not the wrel in the EGOALT file, rather the ahgr2r variable in the wINDRESP file. I think this same variable should have been made available for UndSoc too in the w_INDRESP file, both for comparison with BHPS, as well as for its general importance for the analysis of interactions between HH- and individual-level characteristics.

I'd be happy to share my syntax as soon as it is ready, if anyone else needs it.
Thank you.
Best regards,
Gabriella

#9 Updated by Alita Nandi over 4 years ago

  • % Done changed from 90 to 100

Thank you Gabriella for offering the code.
I will write to you directly about this.
Best wishes,
Alita

#10 Updated by Victoria Nolan over 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF