Project

General

Profile

Support #504

Svy Commands on Stata

Added by Alex Best over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
02/15/2016
Due date:
% Done:

100%

Estimated time:

Description

Hi there,

I am using Wave C in my dissertation and I've read that because Understanding Society's Dataset is so complex, I need to use svy commands on stata to account for this. However, when I do this, I get no standard errors, t values, p values, or confidence intervals. I have used the following command:

svyset c_psu [pweight=c_indscub_xw], strata(c_strata)

and then I put svy: reg y x1 x2
However, it doesn't work and I am not sure why.
Note: 87 strata omitted because they contain no population members.
Note: Missing standard errors because of stratum with single sampling unit.

Does the above mean I need to do this:
svyset c_psu [pweight=c_indscub_xw], strata(c_strata) singleunit(scaled)
then drop alll 87 strata that have been omitted and then do my regressions by putting svy: first??

Thanks in advance,

Alex

Underneath the regression table it says the following:

History

#1 Updated by Alita Nandi over 4 years ago

  • Assignee set to Alex Best
  • % Done changed from 0 to 90

Hello Alex,

Yes use:
svyset c_psu [pweight=c_indscub_xw], strata(c_strata) singleunit(scaled)
svy: reg y x1 x2
But you don't need to drop any strata.

Please take a look at the online course, in particular the worksheet on weights and survey design where this issue of single PSU strata is discussed.: https://www.understandingsociety.ac.uk/documentation/training/online/introduction-course

Best wishes,
Alita

#2 Updated by Victoria Nolan over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF